baserCMS 4系を、MySQLのデフォルトのsql_mode(STRICT_TRANS_TABLES、NO_ZERO_DATE等)が有効な環境に構築すると、特定の操作で突然PDOExceptionが発生することがあります。
原因は、baserCMSが「公開期間の制限なし」を表す慣習的な値として使っている'0000-00-00 00:00:00'(ゼロ日付)です。
(こちらは、主にMySQL 8系で発生することが多いです。)
例、アップローダーでアップした画像に公開日時を設定すると、公開期間内でも
「An Internal Error Has Occurred.」
と表示されてしまう。