baserマーケット/商品詳細ページ
  • RSS
  • facebook
  • X

ようこそゲスト 様 ログイン

  • お買い物ガイド
  • 販売したい方へ
  • マイページ
  • 新規会員登録
  • カートを見る
※ご注意ください※
この商品は、baserCMS4用の商品です。baserCMS5以上のバージョンでは、正常に動作しませんので、ご利用のbaserCMSのバージョンをご確認のうえ、ダウンロードをお願いします。

プラグイン

MysqlZeroDatePatch baserCMS 4対応

画像を拡大する
このエントリーをはてなブックマークに追加
FREE

このプラグインの概要

baserCMS 4系を、MySQLのデフォルトのsql_mode(STRICT_TRANS_TABLES、NO_ZERO_DATE等)が有効な環境に構築すると、特定の操作で突然PDOExceptionが発生することがあります。


原因は、baserCMSが「公開期間の制限なし」を表す慣習的な値として使っている'0000-00-00 00:00:00'(ゼロ日付)です。


(こちらは、主にMySQL 8系で発生することが多いです。)


例、アップローダーでアップした画像に公開日時を設定すると、公開期間内でも


「An Internal Error Has Occurred.」


と表示されてしまう。


 

MysqlZeroDatePatch

レンタルサーバーやお客様が用意したサーバーでは、DB側のsql_mode設定を自由に変更できないケースも多く、地味に困るポイントだったので、この問題を解決できるパッチ用のプラグインとして用意させていただきました。


すでに4系はサポートが終了しているため、この問題がコア側の修正で解消される可能性は低いと考えられます。そのため、アプリケーション側で対処する方法として、こちらをご活用ください。


 

注意

全てのMySQL環境で対応しているわけではありません。


必ず、テスト・動作確認を行なってください。

評価とレビュー

この商品に対するご感想をぜひお寄せください。